jQuery.noConflict()

気がつくと今のテーマでは wp_head() で jQuery がインクルードされている。以前より jQuery.socialbuttonjPlayer を使っているので、自分でもインクルードしていて、2回読み込まれていた。しかも WordPress に入っているのは 1.6.1 だけど、自分で読み込んでいるのは何故か Google Ajax API CDN の 1.4.4 だし。 そりゃまずいだろう。 というわけで自分で読み込むのをやめたら、今度は動かない。調べると jQuery が noConflict モードで動いているので、 「$」 と書いてあるところを「jQuery」としなければならないということらしい。 jPlayer は noConflict でもそのまま動くけど、自分の書いたコードと jQuery.socialbutton は手直しが必要だった。久しぶりに vi で範囲選択置換実行。すっかり忘れている。

:set number :333,$s/\$/jQuery/g

修正は何とか終わった。参考になった記事

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です


*